BRADLEY SMOKER | "Taste the Great Outdoors"

Miscellaneous Topics => Feedback and Help => Topic started by: cbeb1014 on May 16, 2019, 07:33:11 AM

Title: Not getting heat in smoker
Post by: cbeb1014 on May 16, 2019, 07:33:11 AM
My Bradley smoker quit heating. The smoke generator works. I replaced the Heat Element
Is there a fuse on the back that may need replaced? If so do I need to take the panel off? I see a fuse for the smoke generator but that is obviously separate from the smoker. Thanks.
Title: Re: Not getting heat in smoker
Post by: watchdog56 on May 16, 2019, 08:14:59 AM
I have a 6 rack digital and if you take the back off the is an inline fuse that may have blown. I think you can get them at Yard and Pool.
Title: Re: Not getting heat in smoker
Post by: cathouse willy on May 16, 2019, 08:52:24 AM
We need a little more info to be able to help. The model of your smoker and if you're using a pid to control it would help.The outlet for the cabinet on the back of the smoke gen is protected by the fuse on the back of the smoke gen so check that first.An easy test is to plug the cabinet directly into the wall socket, if it doesn't work there then either the inline fuse or the over temp sensor is bad,both are located on the back wall of the cabinet. A multi meter is a big help when trouble shooting.
Title: Re: Not getting heat in smoker
Post by: cbeb1014 on May 21, 2019, 12:06:41 PM
Thanks. So I take that back panel off right? Didn’t seem like there was enough space back there for anything.