Author Topic: junk or just me  (Read 3303 times)

Offline nodak

  • Full Member
  • ***
  • Posts: 320
junk or just me
« on: December 17, 2005, 10:27:15 PM »
Just tried seasoning my smoker and can't get any pucks to advance.

1. Light is on
2. I hear a constant clicking sound
3. I push the button and push and push and push the ------!!! button and nothing.
4. is the operator stupid or is thing a pile of ---- and already broken.

any help wud be appreciated.


Thanks,
frustrated in ND

Offline nsxbill

  • Hero Member
  • *****
  • Posts: 1,184
Re: junk or just me
« Reply #1 on: December 17, 2005, 10:42:02 PM »
Sorry to hear you are having this experience.  I have two of them, and have never experienced this. If you don't get it rocking and rolling, call Bradley Customer Service, and they will take care of you asap.

One thing I would try is to push in the button and then pull on it to make sure it is coming out.  I did and do use electronic circuit board cleaner on my button every 3 months just to make sure it keeps going in and out and doesn't get gummed up.  Shouldn't be  a problem with a new unit though.

Editing my previous post.  I just remembered that one of the people on the list had a problem like this, took the unit apart and found the pin going from the advance arm to the motor was missing or had come out.  You might want to take it apart to take a look.  

Frustrating I am sure when you just got it, and ready to go!

Bill

<i>There is room on earth for all God's creatures....on my plate next to the mashed potatoes.</i>
There is room on earth for all God's creatures....right on my plate next to the mashed potatoes.

Offline car54

  • Hero Member
  • *****
  • Posts: 1,218
Re: junk or just me
« Reply #2 on: December 18, 2005, 12:39:27 AM »
Sorry to hear that you are have problems, it is disappointing. Call Bradley they will give you a new one. If you want and are willing to play with it by take it apart and see if the pin is missing like Bill said.

I have been playing with my smoke generator to understand the problems that some people are having. I put in a replacement motor, not that anything was wrong with mine, but just to see if it could be done. It did work except when the pivot arm reversed directions, it would stop and you would hear a clicking noise which was the gear grinding. If that happens too much your motor is shot. What I did to fix it was to loosen the motor mounting bracket screws so that it find it's own center. It worked no more clicking. Because I believed that there was some misalignment I then put a small washer(0.04 thick)on top of the motor mounting bracket to lower it. I tightened everything up and it worked.

I hope this info will help. If you do play with it let us know. I still would get a new one from Bradley. It should have worked from the beginning, they might even let you keep they old one.

Brad

Offline car54

  • Hero Member
  • *****
  • Posts: 1,218
Re: junk or just me
« Reply #3 on: December 18, 2005, 12:54:12 AM »
Welcome Nodak,

I forgot to say that. The Bradley is a good product. Once you get through this I don't think that you will forget it. There have been some problems with the generator and the forum have been trying to confront Bradley on it.

The group is a bunch of good people with alot of knowledge. We are not fanatics. Keep in touch.

Brad

Offline nodak

  • Full Member
  • ***
  • Posts: 320
Re: junk or just me
« Reply #4 on: December 18, 2005, 03:02:56 AM »
JUst took it apart, and moved the arm manuelly and than it started to work, so I put it back togather, and hauled everything back outside (-7F).  and it didn't work again!!! than heard the clicking (grinding?) again it's to cold, they can send me a new one. something must not be lined up.  

thanks for the help.

Offline jaeger

  • Sr. Member
  • ****
  • Posts: 735
Re: junk or just me
« Reply #5 on: December 18, 2005, 07:21:50 AM »
nodak,
Bradley will send you a new generator. Keep your broken one to use for spare parts.







<font size="4"><b>Doug</b></font id="size4">

Offline Oldman

  • Member Extraordinaire
  • ******
  • Posts: 5,654
Re: junk or just me
« Reply #6 on: December 18, 2005, 12:35:50 PM »
nodak,
During your warranty period Bradley's service is second to none. They generally second day air replacement items~~!

Olds


Click On The Portal To Be Transported To Our Time Tested And Proven Recipes~~!!! 

Offline JJC

  • Hero Member
  • *****
  • Posts: 1,443
    • Castellot Laboratory Webpage
Re: junk or just me
« Reply #7 on: December 18, 2005, 11:58:53 PM »
Hi Mike,

Welcome to the Forum.  Sorry you are having a major problem with your BS.  Frustrating is hardly the word . . . Can't emphasize enough how helpful Bradley CS is--definitely call them first thing tomorrow AM!  Let us know how things work out . . .

John
Newton MA
John
Newton MA

Offline nodak

  • Full Member
  • ***
  • Posts: 320
Re: junk or just me
« Reply #8 on: December 19, 2005, 12:14:36 AM »
Thanks guys will let you know how it turns out. I <s>think</s> know they need a quality control person.

Also would like to know how to stop filling up my email box with notifications, I click ed on the unsubscribe buttons but doesn't help. Advice Please???

Offline nsxbill

  • Hero Member
  • *****
  • Posts: 1,184
Re: junk or just me
« Reply #9 on: December 19, 2005, 12:48:22 AM »
If you clicked on any subscribe buttons you have to go back and click unsubscribe on each thread.   PIA isn't it!

Good luck and Happy Holidays.

Bill

<i>There is room on earth for all God's creatures....on my plate next to the mashed potatoes.</i>
There is room on earth for all God's creatures....right on my plate next to the mashed potatoes.

Offline manxman

  • Member Extraordinaire
  • ******
  • Posts: 2,724
Re: junk or just me
« Reply #10 on: December 19, 2005, 09:40:30 AM »
Hi nodak, welcome to the forum.

I had a faulty arm mechanism on one of my generators, ran the generator with the cover off and watched it cycle, could see the arm mechanism was'nt working properly causing an intermittent problem with puck delivery.

Bradley replaced it straight away.







Manxman.
Manxman

Offline nodak

  • Full Member
  • ***
  • Posts: 320
Re: junk or just me
« Reply #11 on: December 22, 2005, 04:38:19 AM »
Called them Monday and a new generator is on the way, They doubted it would get here this week cuz, warehouse has lots of orders to fill and mail is slow.  I felt frustrared last night and took it apart again; moved arm manuelly and it seemed to work again, til I screwed the cover down, than hangs up again. I can't see anything causing it but did it several times.  I ended up not screwing it down and got the smoker seasoned.  Hoping to at least to smoke some cheese b4 Christmas.  Still  puzzled why it hangs up wheen cover is screwed down nothing touches the moving parts, I know maybe it's possessed, possible ghost from a Christmas past????????

I do see it will take a while to master getting the temperature to stabilize, hoping next week to do a brisket.

Merry Christmas and Happy New Year

"I can respect you and even your opinion, but that doesn't mean I agree with you"

Offline car54

  • Hero Member
  • *****
  • Posts: 1,218
Re: junk or just me
« Reply #12 on: December 22, 2005, 03:41:08 PM »
Nodak,

Are you sure that a wire is not catching the unit. It's strange that it does not work with the cover but works without it.

Brad