Author Topic: the auto advance works but the manual advance for pucks does not  (Read 2200 times)

Offline cousin craig

  • Newbie
  • *
  • Posts: 2
I used my new smoker for the first time today.  I loaded up the pucks hit the manual advance button one puck advanced waited a while hit it again and nothing another puck would not advance.  so i loaded up the rail with pucks to see if the auto advance works and that does but any ideas why the manual advance would not work? thanks

Offline pensrock

  • Member Extraordinaire
  • ******
  • Posts: 5,447
Re: the auto advance works but the manual advance for pucks does not
« Reply #1 on: January 12, 2014, 07:14:29 AM »
Only thing I would be able to suggest is to unplug then replug to reset everything to see it that helps, if not the unplug and take the cover off the smoke generator and see if any wires got knocked loose during shipping. It is possible something came loose in shipping.

Offline GusRobin

  • Member Extraordinaire
  • ******
  • Posts: 4,520
Re: the auto advance works but the manual advance for pucks does not
« Reply #2 on: January 12, 2014, 08:42:09 AM »
make sure your puck tube is in properly and aligned straight
"It ain't worth missing someone from your past- there is a reason they didn't make it to your future."

"Life is tough, it is even tougher when you are stupid"

Don't curse the storm, learn to dance in the rain.

Offline renoman

  • Full Member
  • ***
  • Posts: 425
Re: the auto advance works but the manual advance for pucks does not
« Reply #3 on: January 12, 2014, 08:51:55 AM »
Sounds like a bad or stuck puck advance button. There is no reason for it to advance automatically but not by pressing the wood advance button. Does the wood advance button have the same "feel" as the other buttons?

Offline cousin craig

  • Newbie
  • *
  • Posts: 2
Re: the auto advance works but the manual advance for pucks does not
« Reply #4 on: January 12, 2014, 09:20:01 AM »
Opened it up and everything inside looked good.  Its on straight because the pucks do advance every 20 minutes but when i hit the advance button nothing happens.  And no the button has no feel to it pushes in very easily.  Thanks for all the ideas and help.  It works fine without that button but i would like to get it to work as I just purchased it .

Offline Salmonsmoker

  • Sr. Member
  • ****
  • Posts: 915
Re: the auto advance works but the manual advance for pucks does not
« Reply #5 on: January 12, 2014, 09:48:03 AM »
Sounds like the button switch is faulty. I'd give Bradley a call.
Give a man a beer and he'll waste a day.
Teach him how to brew and he'll waste a lifetime.

Offline Saber 4

  • Member Extraordinaire
  • ******
  • Posts: 3,349
Re: the auto advance works but the manual advance for pucks does not
« Reply #6 on: January 12, 2014, 10:11:13 AM »
Sounds like the button switch is faulty. I'd give Bradley a call.

X2, they will take care of you no problems, just make sure to write down or take a picture of your serial number to give them.