Author Topic: My smoker died :(  (Read 1245 times)

Offline g1ant

  • Newbie
  • *
  • Posts: 4
My smoker died :(
« on: January 20, 2014, 11:18:33 AM »
I have a 4 rack with auto feed.  It was working fine until yesterday.  I left it on overnight to finish a boston butt.  No smoke, just the element on.

Came to it this morning.  Dead as a door post.  Not lights on the control unit.  No nothing.

The fuse on the back is fine.  And its not a power outlet problem.  I checked that also.

any ideas anyone?
« Last Edit: January 20, 2014, 11:21:18 AM by g1ant »

Offline hutcho

  • Jr. Member
  • **
  • Posts: 239
Re: My smoker died :(
« Reply #1 on: January 20, 2014, 11:32:56 AM »
How long did you leave it? The element has a timer.  I have caught mibe turning off on long cooks before.

Sent from my Samsung Galaxy Note 2


Offline g1ant

  • Newbie
  • *
  • Posts: 4
Re: My smoker died :(
« Reply #2 on: January 20, 2014, 11:36:24 AM »
I have the unit off the smoker and on my workbench now.
Plug it in - just dead.  No lights on the unit, no nothing.

beefmann

  • Guest
Re: My smoker died :(
« Reply #3 on: January 20, 2014, 11:37:18 AM »
is it a digital unit? if so, your  timer might have  timed  out,  if it is not a digital unit  check your connections  they may  have become loose,  just read your second post,,,  check the heater with an  ohm meter it  should read  between 28 and 32 ohms,,, if it  reads 0 then you  have a  dead element,,, call bradley, if you  have an  ohm  reading   on the heater   remove the  back panel of the tower and check the fuse able link on the wiring  an d the themister on the back ( looks like a  lil  disk ) if they are  bad , contact bradley
« Last Edit: January 20, 2014, 11:40:48 AM by beefmann »