Author Topic: Getting really frustrated  (Read 5673 times)

Offline KyNola

  • Moderation Team
  • *****
  • Posts: 10,516
  • KCBS CBJ
Re: Getting really frustrated
« Reply #15 on: August 31, 2015, 07:14:42 am »
What are you using to measure the temp in the tower?

Offline warbirdog

  • Newbie
  • *
  • Posts: 8
Re: Getting really frustrated
« Reply #16 on: August 31, 2015, 04:27:52 pm »
 Make sure you have the smoke generator rocker switch "ON", and the rotary tower temp control all the way around.fvdv

Offline mrielly

  • Newbie
  • *
  • Posts: 10
Re: Getting really frustrated
« Reply #17 on: September 02, 2015, 02:46:49 pm »
What are you using to measure the temp in the tower?
The gauge on the door. But I don't even need that to know it's not getting very warm. I left it on high for 3 hours.

Offline mrielly

  • Newbie
  • *
  • Posts: 10
Re: Getting really frustrated
« Reply #18 on: September 02, 2015, 02:49:20 pm »
sounds like one of two  issues, low voltage to the element or a  bad element...  check the voltage at the smoker,... should be between 115 and 120 volts,,, heating element  should  be  between 28 and 32  ohms is  memory serves me right

I changed the heating element.
I wouldn't even know how to check he voltage.

Offline mrielly

  • Newbie
  • *
  • Posts: 10
Re: Getting really frustrated
« Reply #19 on: September 02, 2015, 02:49:51 pm »
You're not running the primary power through an extension cord, are you?  Unless it is a big, heavy duty extension cord, the Bradley will not run properly with it.

I'm not. :(