Author Topic: Troubleshooting a modded, dual element digital Bradley with Auber PID  (Read 1248 times)

Offline Aussie Chaka

  • Newbie
  • *
  • Posts: 7
Hi folks. Just hooked up my new Auber model WSD-1200GPH to my new digital
 bradley smoker as per the diagram in the Operation Instruction Manual for
 the dual probe PID. However, when I power up the smoke generator I get an
 "E1" error come up. The wiring diagram does not indicate how and whether to
 connect up the thin sensor cable that normally is connected between the smoke
 generator and smoker cabinet. When I do connect up the thin sensor cable as
 usual I do not get an "E1" error.
 My question: for correct PID operation must the sensor cable still be connected up
 to the smoke generator and smoker cabinet as when smoking without the PID?
 
 
Bradley 6 rack digital, 2 X 500Watts, Auber PID, Big Daddy cold smoke.

Offline rexster

  • Full Member
  • ***
  • Posts: 440
Yes. That's your cable that tells the digital controller how hot the smoker box is. You'll always get the error unless you keep the cable plugged up or you replace the cable with a null sensor plug.
Stainless 4 rack Bradley
6 Rack DBS w/second heat element
Auber PID
7 Foot X 20" Pipe BBQ pit with offset firebox
Jenn-Air 75000 btu gas grill w/sear burner
Weber Performer charcoal grill
Portable Kitchen All Aluminum Charcoal Grill
2 MES 40" smokers
PK360 Grill
Vacmaster 320 Vacuum Chamber Sealer

Offline Aussie Chaka

  • Newbie
  • *
  • Posts: 7
Thanks Rexster. That makes it easy.
Bradley 6 rack digital, 2 X 500Watts, Auber PID, Big Daddy cold smoke.

Offline Rider14

  • Newbie
  • *
  • Posts: 55
Re: Troubleshooting a modded, dual element digital Bradley with Auber PID
« Reply #3 on: January 16, 2017, 09:29:37 am »
Anyone know the full description for a replacement fuse for the Auberin PID? Can't find one at the hardware store... not sure why it blew but I've used it for years with no issue.

Looks like some type of mini fuse and appears to be 15 amp.

Offline oldsmoker

  • Jr. Member
  • **
  • Posts: 123
Re: Troubleshooting a modded, dual element digital Bradley with Auber PID
« Reply #4 on: January 16, 2017, 04:42:05 pm »
Rider14 had the same fuse go out and found them at auto store . hope that helps.
OLDSMOKER

Offline GusRobin

  • Member Extraordinaire
  • ******
  • Posts: 4,470
Re: Troubleshooting a modded, dual element digital Bradley with Auber PID
« Reply #5 on: January 16, 2017, 04:42:55 pm »
yeah, you can get them at an auto parts store.
"It ain't worth missing someone from your past- there is a reason they didn't make it to your future."

"Life is tough, it is even tougher when you are stupid"

Don't curse the storm, learn to dance in the rain.

Offline Salmonsmoker

  • Sr. Member
  • ****
  • Posts: 882
Re: Troubleshooting a modded, dual element digital Bradley with Auber PID
« Reply #6 on: January 16, 2017, 05:16:44 pm »
I found a replacement at a marine parts store as none of the auto parts stores in my area had one at the time.
Give a man a beer and he'll waste a day.
Teach him how to brew and he'll waste a lifetime.