Author Topic: Pucks not advancing all the time  (Read 1512 times)

Offline speedygd

  • Newbie
  • *
  • Posts: 3
Pucks not advancing all the time
« on: January 12, 2016, 07:09:50 am »
Hello, I am having trouble with the pucks not advancing. When I turn on the smoke generator, I press the puck advance button and I can hear it moving but it doesn't always push a puck out. I usually have to push it two or three times before the puck advances. I have to set a timer and come out every 22-25 minutes to make sure a puck moves and advance one if it isn't. I have removed the housing an observed the motor and arm mechanism operate. What happens is normally the arm on the motor moves clockwise (I know that all depends on from what angle you are viewing if it is clockwise or counter clockwise) and the puck advances just fine, but periodically the motor will move in the counter clockwise direction and that is when the puck will not advance. I thought it was the motor so I purchased and installed a new one and it does the same thing. I have cleaned out the chute as well which also did not solve the problem. Any suggestions as to what else can I do to solve this very frustrating problem?

Offline TedEbear

  • Member Extraordinaire
  • ******
  • Posts: 2,383
Re: Pucks not advancing all the time
« Reply #1 on: January 12, 2016, 09:05:14 am »
First, welcome to the forum.  The link below is a general troubleshooting guide on problems with the puck not advancing.

Why won’t my bisquettes advance when I push the Advance button?

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 14,023
  • KCBS - Master Certified Barbecue Judge
Re: Pucks not advancing all the time
« Reply #2 on: January 12, 2016, 01:01:44 pm »
Hi speedygd;

Welcome to the forum.

In addition to the link TedEbear posted, I found that the main problem is the push plate rail(s) is out of alignment. Depending on your point of view, when the motor turns counterclockwise, more pressure is put on the left rail. When it is running clockwise, more pressure is placed on the right rail. You can see this if you watch closely as the motor advances the "pusher". If you don't notice this, look for wear, as instructed in the post, and align the rail.


     I
         don't
                   inhale.
  ::)

Offline speedygd

  • Newbie
  • *
  • Posts: 3
Re: Pucks not advancing all the time
« Reply #3 on: January 13, 2016, 06:57:00 pm »
Hello and thank you for your replies and advice. I will try the rail realignment in the next day or two and let you all know if it worked. Thanks again for the advice and the link to the troubleshooting guide.

Offline speedygd

  • Newbie
  • *
  • Posts: 3
Re: Pucks not advancing all the time
« Reply #4 on: January 15, 2016, 01:18:41 pm »
Hello again. Inspected and found a bit or wear on the pusher. Realigned the rails and initial results are positive. I will try a smoke this weekend and see if the repair holds. Thanks a bunch for the advice!

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 14,023
  • KCBS - Master Certified Barbecue Judge
Re: Pucks not advancing all the time
« Reply #5 on: January 16, 2016, 02:13:40 am »
Glad to see you are up and running smoothly again.


     I
         don't
                   inhale.
  ::)