Author Topic: Smart Smoker Problem  (Read 691 times)

Offline rbejr

  • Newbie
  • *
  • Posts: 1
Smart Smoker Problem
« on: February 26, 2017, 08:00:11 am »
I tried my smart smoker for the first time this weekend, and it ran fine for several hours during the seasoning process that Bradley recommends in the owner's manual.  Then, when I tried my first cook with meat inside, it started having problems.  It worked fine for about an hour, then I came out and the screen was blinking, and saying the unit had overheated.  I reset it and despite the temperature outside being in the 30's it was still reading a temperature around 160.  After several minutes it started saying it had overheated again, even though it was only set to 250, and the actual internal temperature was much lower than that.  I reset it again and this time the temerature reading was in the higher 200's, and the unit almost immeadiately said it was overheating.  Anyone have this problem?  I was unable to use it and had to revert back to my old digital model to finish the cook.

Offline Toker

  • Hero Member
  • *****
  • Posts: 1,045
Re: Smart Smoker Problem
« Reply #1 on: February 26, 2017, 04:21:16 pm »
Mine act exactly the same sometimes and I still don't know why.

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 13,940
  • KCBS - Master Certified Barbecue Judge
Re: Smart Smoker Problem
« Reply #2 on: February 27, 2017, 01:54:07 am »
You should give Bradley a call.


     I
         don't
                   inhale.
  ::)

Offline Olev

  • Moderation Team
  • *****
  • Posts: 12
Re: Smart Smoker Problem
« Reply #3 on: February 27, 2017, 07:47:00 am »
Mine act exactly the same sometimes and I still don't know why.

Hi toker and rbejr, try to set your temperature to 180, run it about an hour and raise it to 200 run it a while and then take it up another 20 degrees again to see if it helps.

cheers,
Olev

Offline Toker

  • Hero Member
  • *****
  • Posts: 1,045
Re: Smart Smoker Problem
« Reply #4 on: February 27, 2017, 09:11:32 am »
Anything lower than 180 result in over heating warning and the smoker turn off by it self. The problem seems to come from the OVEN section cause once I've tried heating with my pid controller and the display was ok. As soon as i touch the OVEN section, the display start acting wrong. I tried 3 différents sensor (Bradley digital sensor) So i can certify that the sensor is not the problem. Must be the smoke generator, not the tower. No problem at all with the SMOKE section. I've also measured the temp with an Igrill probe placed next to the sensor and I had 60 degrees différence. (Both probe were 2 cm from each other) The Bradley temp on the smoke generator was 60 higher. And when I used my pid, the difference was much lower. This is why I RREALLY think that my OVEN section is faulty but I could be wrong. BTW the 2 probes are accurate, I tested them.

Could you send me a new smoke generator for me to see if it fix the problem, is it included in the warranty?
« Last Edit: February 27, 2017, 09:37:46 am by Toker »