Author Topic: Smoke Generator Issues  (Read 331 times)

Offline AlbertaAdvantage

  • Newbie
  • *
  • Posts: 2
Smoke Generator Issues
« on: October 07, 2017, 07:59:12 am »
My 2 year old BTDS108P started acting up. When the generator is plugged in the screen will make 1 little flash every few seconds along with an audible "click".  The generator will not power up at all.

Any suggestions?

Offline AlbertaAdvantage

  • Newbie
  • *
  • Posts: 2
Re: Smoke Generator Issues
« Reply #1 on: October 07, 2017, 08:27:42 am »
And it's not any kind of pattern that flashes on the screen

Offline tskeeter

  • Hero Member
  • *****
  • Posts: 1,018
Re: Smoke Generator Issues
« Reply #2 on: October 07, 2017, 04:53:11 pm »
Sounds like you have power to the smoke generator.  I think I’d start by taking the shroud off the smoke generator and looking for a wire that is disconnected or loose.  Since the display is acting wonky, I’d look there first.

I’m guessing that the clicking is the puck pusher.  You might give that a once over, too.  To make sure it cycles properly and isn’t binding on some obstruction.

When you go to take the shroud off the smoke generator, remember that you only need to remove the screws around the perimeter of the bottom.  The screws in the center of the bottom hold components in place.

If you don’t find something obvious, I’d make a call to Bradley customer service for some diagnostic assistance.

Offline Gafala

  • Full Member
  • ***
  • Posts: 498
  • Gem faceter by choice, BBQ Smoker by heart.
Re: Smoke Generator Issues
« Reply #3 on: October 08, 2017, 09:44:50 am »
Sound advice.
Bradley 4 rack Digital, 900 watt, Auber PID
Bradley cold smoke adapter
Char-Griller Smoking Pro BBQ Smoker with rotisserie
Brinkman Bullet Smoker
Weber 24”
Custom Hard Cure Cabinet for Salami
One Auber Master Temp monitor and two remotes with probes, up to ten remotes can be used.

Offline Handyman

  • Newbie
  • *
  • Posts: 13
Re: Smoke Generator Issues
« Reply #4 on: October 18, 2017, 11:03:33 am »
My 2 year old BTDS108P started acting up. When the generator is plugged in the screen will make 1 little flash every few seconds along with an audible "click".  The generator will not power up at all.

Any suggestions?
I just had that problem yesterday and I had a loose AC plug.

Make sure all plugs are pushed in securely.