Author Topic: No heat in my smoker  (Read 171 times)

Offline Toolman Mike

  • Newbie
  • *
  • Posts: 2
No heat in my smoker
« on: July 29, 2018, 10:43:51 am »
Hi...new to the chat so here goes....My digital Bradley smoker over temped and now I can't get the main heater bar to heat.  I unplugged/plugged all the connections, cycled the main power, reset the oven temp to 200 degrees, changed the heater bar...but still can't get it to heat.  The smoker function does work fine.  Can anyone help?

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 14,342
  • KCBS - Master Certified Barbecue Judge
Re: No heat in my smoker
« Reply #1 on: July 29, 2018, 01:36:29 pm »
Hi Toolman Mike;

Welcome to the forum.

You may have blown the inline fuse. The fuse is located by taking the back panel of the cabinet off. If you have a multimeter; once you get the back off, test the fuse for continuity, to see if it has blown.

There is also a temperature sensor, that will shut off the element if the cabinet goes beyond a certain temperature. These are suppose to reset once the cabinet cools down, but they have been known to fail. If it fails it must be replaced. You can see the sensor when you look inside the cabinet. It is about the size of a quarter. To replace it you will need to remove the back panel of the cabinet.


     I
         don't
                   inhale.
  ::)

Offline Toolman Mike

  • Newbie
  • *
  • Posts: 2
Re: No heat in my smoker
« Reply #2 on: July 29, 2018, 01:52:01 pm »
Thanks Hab.  Guess I need to take the back off.

TM