Author Topic: Problems with temp  (Read 234 times)

Offline tomdw

  • Newbie
  • *
  • Posts: 1
Problems with temp
« on: November 18, 2018, 06:32:30 am »
I have a 5 or 6 year old digital smoker that has worked great the entire time I've had it.  I started last evening smoking some brisket.  My normal routine is to put it on at night and smoke overnight.  After getting the smoker up to temp I set the temp at 200.  Everything was working fine as I checked it through the night.  About 7am this morning the temp was set to 200, but the actual temp was showing 275.  I opened the cabinet, but the temp didn't feel like it was hotter than 200ish.  I turned everything off and turned it back on.  I set the temp at 200 and the overall temp seemed to come down to around 225.  I left it alone thinking it had corrected itself.  I checked back around 45 minutes later and the overall temp is now at 275 again even though it is set for 200.  At this point I took off the meat so I could finish it in the oven because there doesn't seem to be any heat coming from the smoker cabinet.  I turned off the smoker and removed and reconnected the temp sensor cable.  I turned the smoker back on, but it's still exhibiting the same problems.  I haven't investigated thoroughly yet, but wondering if anyone else has had this problem?  Thanks.

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 14,393
  • KCBS - Master Certified Barbecue Judge
Re: Problems with temp
« Reply #1 on: November 18, 2018, 01:12:33 pm »
Hi tomdw,

Just to clarify part of your problem, are you saying that at the time you took the brisket out of the cabinet the heating element was not producing any heat? Did you get any error codes? Also are you using a third party temperature probe, if so what type?

I don't have a digital, but I haven't read anything about others having the same problem as you are. I would start by cleaning the temperature sensor off, and checking the sensor contacts to make sure they are clean and free of debris.

Other problem areas could be you may have some type of short in the sensor cord, so that may need to be replaced, or the sensor itself may need to be replaced.



     I
         don't
                   inhale.
  ::)

Offline TwistedSanity

  • Newbie
  • *
  • Posts: 54
Re: Problems with temp
« Reply #2 on: November 20, 2018, 10:55:12 am »
Further to Hab's suggestions I would also get a wireless temp prob.  I routinely use one to keep an eye on the actually over temp.  I often find a difference between the Bradley's posted temp and the over temp at the level of the meat.


Offline Closerox

  • Newbie
  • *
  • Posts: 2
Re: Problems with temp
« Reply #3 on: December 11, 2018, 01:25:40 am »
Agreed on this. But I think we're going to add a bit more information.