Author Topic: Auber WSD 1200GHP and 900 W conversion  (Read 1052 times)

Offline bedfordbruisers

  • Newbie
  • *
  • Posts: 7
Auber WSD 1200GHP and 900 W conversion
« on: September 19, 2019, 12:24:03 PM »
I, like many, had many issues with the smoker getting to a temperature even close to acceptable. I just purchased the 900 watt tempco element as well as the 1200GHP Auber PID. I was wondering if there are any settings that I need to change on the PID since I did the upgrade, or if I can just plug and play. Also, after doing the upgrade and testing, I still couldn't get the smoker above 150 after 25 minutes. I then realized I accidentally purchased the 240v rather than the 120V. I have ordered the correct part, but I am curious as to if the wrong voltage element is the only issue I have. Could the temp sensor be bad?

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 14,768
  • KCBS - Master Certified Barbecue Judge
Re: Auber WSD 1200GHP and 900 W conversion
« Reply #1 on: September 19, 2019, 02:41:00 PM »
Hi bedfordbruisers;

Welcome to the forum.

As to your heating problem, another member had the same heating issue when he ordered the 240v by mistake. After replacing the 240v for a 120v the problem was resolved.


     I
         don't
                   inhale.
  ::)

Offline TedEbear

  • Member Extraordinaire
  • ******
  • Posts: 2,587
Re: Auber WSD 1200GHP and 900 W conversion
« Reply #2 on: September 21, 2019, 06:42:59 AM »
I was wondering if there are any settings that I need to change on the PID since I did the upgrade, or if I can just plug and play.

Simulate a load of meat in the smoker (several cold bricks or something) and run the autotune and let it do its thing.

Offline DanKhile

  • Newbie
  • *
  • Posts: 2
Re: Auber WSD 1200GHP and 900 W conversion Troubleshool Auto Tune
« Reply #3 on: May 22, 2020, 06:55:41 AM »
I purchased the 900W element, the internal fan and the WSD 1200GPH PID Controller - when I try to Autotune the Controller due tot he 900 watt element - it does not respect my temp.  I set C1 to 250 and the duration for 5 hours - placed a big old sacrificial roast in the smoker to represent my "Load" plugged in the L2 probe into the roast. Oven temp showed 67 - Meat temp showed 42.  Cycled thru LCK entered 166 went to AT changed form 0 to 1 cycled thru till it blinked AT and 67 alternately.  Watched the temp go to 305 - figured it was hitting high limits to calibrate.  Left smoker going all day - 8 hours later it was alternating AT 255 with a meat temp of 241.  I have since retried with simulation of A cast iron pan filled iwth water and same results - dan @ Khile.com

Offline TedEbear

  • Member Extraordinaire
  • ******
  • Posts: 2,587
Re: Auber WSD 1200GHP and 900 W conversion Troubleshool Auto Tune
« Reply #4 on: May 22, 2020, 08:25:42 PM »
I purchased the 900W element, the internal fan and the WSD 1200GPH PID Controller - when I try to Autotune the Controller due tot he 900 watt element - it does not respect my temp.  I set C1 to 250 and the duration for 5 hours - placed a big old sacrificial roast in the smoker to represent my "Load" plugged in the L2 probe into the roast. Oven temp showed 67 - Meat temp showed 42.  Cycled thru LCK entered 166 went to AT changed form 0 to 1 cycled thru till it blinked AT and 67 alternately.  Watched the temp go to 305 - figured it was hitting high limits to calibrate.  Left smoker going all day - 8 hours later it was alternating AT 255 with a meat temp of 241.  I have since retried with simulation of A cast iron pan filled iwth water and same results - dan @ Khile.com

There's another recent thread on the autotune.  You might want to read through it for some ideas. 

Click on the link: Autotune