Author Topic: HELP ! Smoker test results  (Read 6471 times)

Offline GABJR

  • Newbie
  • *
  • Posts: 48
HELP ! Smoker test results
« on: September 12, 2007, 04:45:32 PM »
I need HELP. I have had my smoker oven going for one hour @ 250 degrees. I did not turn on the smoke generator. Using my meat thermometer probe through the damper, hanging at mid level in the smoker, the temperature is 81 degrees. I started at 84, but the sun is going down.
Please advise what to do next. ???

NePaSmoKer

  • Guest
Re: HELP ! Smoker test results
« Reply #1 on: September 12, 2007, 05:12:21 PM »
Make sure the V-tray vents are not blocked in any way. also you can see if the tube is glowing, close the top vent to see if the heat comes up any.

nepas

Offline GABJR

  • Newbie
  • *
  • Posts: 48
Re: HELP ! Smoker test results
« Reply #2 on: September 12, 2007, 05:34:12 PM »
coming up on hour 2. the temperature is droping. The tube is not glowing and is not even warm to the touch

Offline Consiglieri

  • Hero Member
  • *****
  • Posts: 1,099
  • Sasquatch like ribs
Re: HELP ! Smoker test results
« Reply #3 on: September 12, 2007, 05:37:19 PM »
check your power connections on the back of the smoke generator and the box.  Give them a good push in and then check for glowing and temp change in the correct direction.
Consiglieri

NePaSmoKer

  • Guest
Re: HELP ! Smoker test results
« Reply #4 on: September 12, 2007, 05:42:45 PM »
yep sounds like you might have a bad connection.

nepas

Offline GABJR

  • Newbie
  • *
  • Posts: 48
Re: HELP ! Smoker test results
« Reply #5 on: September 12, 2007, 05:44:31 PM »
checked all connections. no glow. temperature still dropping

Offline Wildcat

  • Member Extraordinaire
  • ******
  • Posts: 4,848
Re: HELP ! Smoker test results
« Reply #6 on: September 12, 2007, 05:44:49 PM »
Be sure to push slider to the right.
Life is short. Smile while you still have teeth.



CLICK HERE for Recipe Site:  http://www.susanminor.org/

NePaSmoKer

  • Guest
Re: HELP ! Smoker test results
« Reply #7 on: September 12, 2007, 05:46:10 PM »
is your fuse blown?


nepas

Offline Wildcat

  • Member Extraordinaire
  • ******
  • Posts: 4,848
Re: HELP ! Smoker test results
« Reply #8 on: September 12, 2007, 05:46:26 PM »
Also, you may want to plug a lamp into the outlet to be sure that you do not have a tripped circuit breaker.
Life is short. Smile while you still have teeth.



CLICK HERE for Recipe Site:  http://www.susanminor.org/

Offline GABJR

  • Newbie
  • *
  • Posts: 48
Re: HELP ! Smoker test results
« Reply #9 on: September 12, 2007, 05:50:33 PM »
this is a digital smoker. I checked the fuse earlier. I am getting power to the control box & the smoke generator was hot to touch immediately when I started the test. I then turned the smoke generator off to check the oven

Offline Mr Walleye

  • Member Extraordinaire
  • ******
  • Posts: 5,336
Re: HELP ! Smoker test results
« Reply #10 on: September 12, 2007, 05:54:58 PM »
Unplug and re-plug in all connections and make sure they are seated all the way in correctly. Then turn the unit back on and see if the element in the tower starts to get warm.

Is the display showing your target temp and your actual temp?

Mike

Click On The Smoker For Our Time Tested And Proven Recipes


Offline GABJR

  • Newbie
  • *
  • Posts: 48
Re: HELP ! Smoker test results
« Reply #11 on: September 12, 2007, 06:24:07 PM »
I shut everything down. unplugged, checked the fuse, reconnected. I set the oven. the display shows the actual temp & set temp.
still no glow or heat.

Offline Mr Walleye

  • Member Extraordinaire
  • ******
  • Posts: 5,336
Re: HELP ! Smoker test results
« Reply #12 on: September 12, 2007, 06:42:57 PM »
I have seen some talk before about the connections being loose on the heat bulb in the back of the tower. I also remember them warning about over tightening them because the bases are made out of porcelain.

This seems very strange because if there is a connection issue it usually either shuts off the display or shows an error message.

Gotta think on this.... anybody else have any ideas?

Mike

Click On The Smoker For Our Time Tested And Proven Recipes


Offline Mr Walleye

  • Member Extraordinaire
  • ******
  • Posts: 5,336
Re: HELP ! Smoker test results
« Reply #13 on: September 12, 2007, 07:42:15 PM »
GABJR

Try plugging the element in the tower in directly using the power supply cord for the smoke generator and see if it heats up. If the heater works during this test then it has to be in the smoke generator and I would definitely give Brian Nelson a call at Bradley.

Here is a post with just about the same problem.

 http://forum.bradleysmoker.com/index.php?topic=4990.0

Mike

Click On The Smoker For Our Time Tested And Proven Recipes


Offline GABJR

  • Newbie
  • *
  • Posts: 48
Re: HELP ! Smoker test results
« Reply #14 on: September 12, 2007, 08:06:12 PM »
I just tried power directly to the tower & the tube did not glow. thanks everyone. I will call Bradley tomorrow