Author Topic: Help..I think I fried it!!!  (Read 16149 times)

Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Help..I think I fried it!!!
« on: April 26, 2008, 04:03:33 PM »
Got busy making chick wraps and ABT's next thing I know temps @ 370 on my maverick while doing ribs (my bad).....AAAHHHHHHH, got the temp back down, but now I have now power to the cabinet, smoke gen is working fine, so did I toast it, is there a reset, HELP!!!!!!!

Thanks

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline Smoking Duck

  • Member Extraordinaire
  • ******
  • Posts: 2,836
    • La Cosa Smokestra Blog
Re: Help..I think I fried it!!!
« Reply #1 on: April 26, 2008, 04:06:57 PM »
Not sure WTS.  Could it possibly be a fuse?  Hopefully one of our esteemed electrical gurus will be around soon to help.

Steeler....she's a keeper!

Who doesn't love lab puppies?


Click here for my blog: La Cosa Smokestra

Offline Arcs_n_Sparks

  • Hero Member
  • *****
  • Posts: 1,294
Re: Help..I think I fried it!!!
« Reply #2 on: April 26, 2008, 04:08:20 PM »
westexasmoker,

Temperature needs to come down enough for the thermal breaker to reset. Not sure what that is....

Arcs_n_Sparks

Offline Smoking Duck

  • Member Extraordinaire
  • ******
  • Posts: 2,836
    • La Cosa Smokestra Blog
Re: Help..I think I fried it!!!
« Reply #3 on: April 26, 2008, 04:09:45 PM »
westexasmoker,

Temperature needs to come down enough for the thermal breaker to reset. Not sure what that is....

Arcs_n_Sparks

I knew one of our esteemed electrical geniuses would be around soon. ;D

Steeler....she's a keeper!

Who doesn't love lab puppies?


Click here for my blog: La Cosa Smokestra

Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Re: Help..I think I fried it!!!
« Reply #4 on: April 26, 2008, 04:47:09 PM »
Ok....been about 1.5 hours, I left the temp on high and smoke gen on and working @ 168 slowing climbing, should I turn the whole thing off, or keep going to see where we land....I'm so p'od at myself for letting it get that high...By that same token, I've never seen it try to get that high so fast...Oh well live and learn  ;D 

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Re: Help..I think I fried it!!!
« Reply #5 on: April 26, 2008, 05:22:20 PM »
OK here's the plan..everything is pulled off into the oven, I'm at 178...just slow to get there.  Gonna shutdown, plan on Salmon tommorrw so we'll see....Anybody else have this (my) problem....Thanks guys!

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline Mr Walleye

  • Member Extraordinaire
  • ******
  • Posts: 5,336
Re: Help..I think I fried it!!!
« Reply #6 on: April 26, 2008, 05:25:56 PM »
Westex

If it is empty now I would let it cool off then fire it back up and make sure the cabinet heater is glowing red. If it is I wouldn't think there is any problem.

Mike

Click On The Smoker For Our Time Tested And Proven Recipes


Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Re: Help..I think I fried it!!!
« Reply #7 on: April 26, 2008, 06:44:32 PM »
Gut instinct tells me somehow I toast'd the element...but then again before I shut'her down I had a temp raise to 178 ...SLOW,,so not sure.....We'll see tomorrow...My luck I kill it within a month...(hence as my father in law tells me, "you could screw up, an anvil with a ball pen hamer")  Not mater what happens I'll be back!!!!!!!!

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline West Coast Kansan

  • Member Extraordinaire
  • ******
  • Posts: 2,093
Re: Help..I think I fried it!!!
« Reply #8 on: April 26, 2008, 11:49:27 PM »
Sounds like the temp cut off tripping.  Once tripped i think I have read they may trip again at a lower temp (like 220 to 280 instead of the 340 or so they cut out at when new - all just memory so dont quote the numbers).

If it does not come up to temp during the exercise Mr Walleye suggests, this may be the problem... I saw a picture of one inside the back tower cover.  Does not look hard to replace.  I am sure Bradley has plenty.  Hope you have good luck and it is all reset just fine. 

Click On Link For Our Time Tested And Proven Recipes and Register at this site for Tuesday Night Chat Room Chat is FUN!

NOW THAT'S A SMOKED OYSTER (and some scallops)

Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Re: Help..I think I fried it!!!
« Reply #9 on: April 27, 2008, 11:31:39 AM »
Well the news is its dead, heating element not glowing at all and the power indicator light not glowing....I'm so depressed and to make matters worse I've got my salmon on the drying racks, I guess its time to crank up old faithful.  Anybody have any other ideas???  I reckon I'll call Bradley heaven tommorrow!

Thanks

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline La Quinta

  • Member Extraordinaire
  • ******
  • Posts: 3,561
Re: Help..I think I fried it!!!
« Reply #10 on: April 27, 2008, 12:39:44 PM »
That sucks westexas...thanks for sharing though...at least we (I) know...it can happen. Get a new element and you'll be on your way again?

Offline pensrock

  • Member Extraordinaire
  • ******
  • Posts: 5,447
Re: Help..I think I fried it!!!
« Reply #11 on: April 27, 2008, 12:47:40 PM »
Are you sure there is not a fuse somewhere? I do not own a OBS but I cannot imagine not fusing the circuit to the heating element. Also if there is a high limit cutout, it should open before any damage to the element can occur. Maybe the cutout opened and is not resetting. I would not assume its the element till doing a little troubleshooting. If its just a fuse you should still be able to get your salmon smoked.
Good luck.

Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Re: Help..I think I fried it!!!
« Reply #12 on: April 27, 2008, 12:49:49 PM »
I just did'nt think I could kill it...You know the very first night UPS dropped off the smoker, seasoned up and threw a brisket in at 20:00 at 00:00 I refilled the water bowl and the temp dropped so I turned it up to high to bring the temp up before I went to bed...well fell asleep and woke up at 05:00 temp was at 252, so I don't have a clue how it got to 370 in about 2 hrs give or take... ???  And another thing I don't savvy is why the power light is not even coming on, unless its related to the element...Oh well such is life!!

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline westexasmoker

  • Member Extraordinaire
  • ******
  • Posts: 2,104
  • Mesquite...what theres other wood!!
Re: Help..I think I fried it!!!
« Reply #13 on: April 27, 2008, 12:51:37 PM »
The only fuse that I can see is on the smoke gen...I don't know if theres another one maybe dropping the back panel??????

C
Its amazing what one can accomplish when one doesn't know what one can't do!

Offline pensrock

  • Member Extraordinaire
  • ******
  • Posts: 5,447
Re: Help..I think I fried it!!!
« Reply #14 on: April 27, 2008, 01:05:47 PM »
I would open up the back panel to see if there is anything like a burned off wire, fuse, loose connection. You would think if there were a fuse it would be where you could check it easily without taking the back off. It doesn't hurt to look....... that is unless you forget to unplug it before messing with the wires.  ;) ;)