New BDS 6-Rack - Issue with E error message

Started by GMan, March 13, 2010, 06:46:55 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


First, many thanks to all the folks on here for all your hard work to keep this a great community. I can tell you that this forum is the reason that I recently purchased a new digital 6-rack. I look forward to being a long term member.

I just received, assembled, and seasoned my new smoker today - but have been having an issue with the smoke generator. The display blinks E (and beeps), and advances all the wood pucks into my water bowl. I have read the instructions for cleaning the unit, and have also taken it apart and reconnected all the wires relating to the puck advancement switch and motor. It still has issues and now every time I turn on the smoke generator - it advances a puck or two, then starts with the E and the beeping, and continues to advance the pucks into the water bowl.

I currently have two 8lb butts in the unit, and am just using it as a slow oven, because I cannot get the smoker generator up and running. I guess ill be calling tech support on Monday at this point, but if you have other thoughts - I would appreciate it. Thanks everyone and don't forget to spring forward.


Habanero Smoker

Hi gmartin03 and lunatik;

Welcome to the forum.

You can find many trouble shooting tips by clicking on the following link.

Bradley Smoker FAQ's



Thanks guys for the help. I reviewed that information on the "E" error and cleaning the smoke generator. I have confirmed that the unit is clean, nothing is blocking the motor, arm, etc for the puck feed, and the wires are hooked up (I even disconnected them and put them back together). The one thing that I could not do was disconnect the wires from the micro switch. The factory seems to be shrink wrapping the wires to the switch so they cannot be disconnected without cutting off the shrink tape.

Still no joy & I have wasted a ton of apple wood pucks in the process. Lets hope this can be fixed this week. Thanks again for the tips.

Bradley (Head Office)

Hi Greg

Try this and see if it helps.
.To test the micro switch plug the generator in and then push the wood advance button when the motor starts to turn push the black button on the micro switch with your finger the motor should stop when the button is depressed. If the motor stops when you push the button with your finger the switch needs to be moved closer to the motor by losing the two mounting screws and moving the switch closer to the motor.If the motor continues to turn you have a defective micro switch.

Here is a picture of what you should be looking for

If this does not help give the office a call on Monday



Thanks Brian!

I tried pressing the switch manually, and it did indeed stop the advance of the next puck. I then unscrewed the micro-switch, poped it off with a screwdriver, and move it over a bit. I secured one end with the screw and other other end with a bit of super glue. I would suggest making the screws a bit longer if possible on the next order - it was a difficult fit. Lets just hope the glue holds, but I know what to do next time. I ran it for four hours, and it continued to work fine.

Thanks again for the help.

Bradley (Head Office)

Your Welcome Greg

Glad you have it working

We cannot put a longer screw in because the the push plate for the bisquette would hit it.

You can also loosen the mounting screws on the motor and its mounting bracket and move the motor closer
to the switch as well.