Element out after two uses

Started by Cweed38, May 15, 2011, 11:23:17 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I bought a new Bradley about a month ago and have used it twice with good results.  i do wish it had a stronger element to get the heat up to 225 after you add food ... but that's not my immediate problem.  I bought meat, prepared it yesterday, invited people over for dinner and today the element doesn't work.  We used the forums to check everything and still nothing.  Power works to the bisquette feeder, but not the element (light doesn't even come on for the unit).  We tried connecting the power direct to the unit and still nothing.  It seems to be the element, and I can't do anything about it today (with guests scheduled for dinner) so am very frustrated.  And it seems that this is a common problem, so my question is why doesn't Bradley send the units out with a back-up element to begin with?  This leaves a new customer, who was singing Bradley's praises, in a bad spot.


Quote from: Cweed38 on May 15, 2011, 11:23:17 AMPower works to the bisquette feeder, but not the element (light doesn't even come on for the unit).  We tried connecting the power direct to the unit and still nothing.  

That's not a bad element.  Even with a defective element the little red power light would still come on.  Sounds like a bad inline fuse, which you'll have to remove the back panel of the cooking chamber to check.  Use a multimeter with a continuity checker to test if it is good.  You cannot tell by just a visual inspection.  Also, unplug and reconnect the wires going to the plug on the inside of the chamber back panel.  They have been known to come loose. Additionally, if everything thus far checks out inspect all other wire connections in the chamber, especially the ones that connect to the circuit board.

Here's what the linline fuse looks like:

Also, add a second element someday if you want to get things up to temp faster.  Many of us did that mod and I feel it is something the Bradley should have come with in the first place.  Make sure you add a PID controller at the same time for the higher current.

Meat tooth

Check and make sure the short cord is plugged in tight. This happened to me -kinda embarrassing for a tech- If that isn't the problem, then I suspect either a defect in the control board, or a poor connection to it. Thats a real bummer, but contact Bradley by phon and they will take care of it. The customer service is among the best I've experienced.
Chew carefully and don't let your meat loaf.

Tiny Tim

I'm assuming you bought the OBS, so that's where my question/advice comes from.  On some units, if the slider switch is full to the right side, there is a dead spot...just have to bump it back 1/8 inch or so to the left.


Double check your plugs. When new they tend to be sticky and if you unplug and replug them they will make better contact. And make sure they are pushed in good. This has fixed so many problems. Sorry you had this happen at a critical time.
I like to walk threw life on the path of least resistance. But sometimes the path needs a good kick in the ass.

One Big Easy, plus one in a box.