Author Topic: p10 no smoke  (Read 393 times)

Offline happycamper

  • Newbie
  • *
  • Posts: 1
p10 no smoke
« on: August 23, 2022, 09:29:25 am »
has anyone had an issue with no smoke.the box heats up fine,ive only used my smoker 5 times its coming up to the 1 year old date.ive reached in and took the puck out,just started on 4 racks of salmon.i cant see a fuse anywhere. set the smoker to 140f then 5 hrs time,with 4 hrs smoke,pucks are dropping without a burn mark.

thank you for your time

mike



Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 15,237
  • KCBS - Master Certified Barbecue Judge
Re: p10 no smoke
« Reply #1 on: August 23, 2022, 01:24:27 pm »
Hi happycamper,

Welcome to the forum.

You should contact Bradley right away, since your warranty is about to expire.

Your problem is extremely unusual. If the bisquette burners do not work, that should shut your P10 down. There are bisquette heat sensors, and if they don't detect a certain amount of heat within in a certain amount of time, it will disable your heating elements. At least that is what happen to mine, but Bradley may have change that function in later firmware upgrades.

if the bisquettes are sitting on the burners for approximately 20 minutes and do not smolder, then the issue is your bisquette burners. If the bisquettes are just cycling through without resting on the burners, then there is a problem with the turntable. Either problem it is best to contact Bradley.


     I
         don't
                   inhale.
  ::)