Tempco test?

Started by Kalamazoo, July 15, 2023, 02:00:01 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


About five years ago, I upgraded my Bradley with an Auber PID, Tempco heating element, etc. per all the awesome forum instructions. It has worked magnificently. About a month ago I overloaded it with pork shoulder and caused a grease fire where it went to above 300°, fortunately nobody got hurt. I stripped out all the components from the old smoker and I've put it into a new classic Bradley and today tried it for the first time. It seemed to work flawlessly for about six hours but suddenly now it's no longer generating heat. Is there anything other than the heating element going bad that I need to check? How do I check that?

Sent from my iPhone using Tapatalk

Habanero Smoker

Sorry! I don't have much time to search for the thread. If you have the New Bradley Original that has the temperature adjustment on the generator, you may want to do a search on how a member did that modification. There may be some difference in wiring the element.

You didn't mention if any power lights were on. There are a few things that can cause the element not to heat. Usually it is the in-line fuse that will cause the problem, if that blows it will need to be replaced. Also the temperature sensor could have gone bad. Both of these problems are caused by high temperatures.

But the first thing you should do is unhook the PID and see if the Bradley will heat without the PID attached. If it does then the issue is with the PID.



Click on the link below for another thread on troubleshooting a bad heating element and more. 

No Heat