Author Topic: P10 - Suddenly no smoke, no error message, no other issues  (Read 361 times)

Offline DrMikeG2

  • Newbie
  • *
  • Posts: 2
P10 - Suddenly no smoke, no error message, no other issues
« on: August 27, 2023, 07:12:00 am »
I've used my P10 for a few years with ZERO issues.  Went to smoke some serrano peppers and NO problems entering the cook temp, cook time, smoke time.  Unit acting normally.  After an hour, I went to check and no smoke and 2 completely unheated pucks in the water.  No error messages.  Just a ton of heated, unsmoked serrano peppers.  I've cleaned all I can clean.  No fuse to check.  Even TOUCHED the briquette burner plate and it was cool.  Updated firmware, no change.  It has been sitting, covered without any damage for a month since my last smoke session.  Nothing changed except I bragged to family and friends about how well it works and advised they buy one (jinx?).  haha

Any ideas?  I've got a garden to smoke.

Offline Habanero Smoker

  • Member Extraordinaire
  • ******
  • Posts: 15,311
  • KCBS - Master Certified Barbecue Judge
Re: P10 - Suddenly no smoke, no error message, no other issues
« Reply #1 on: August 27, 2023, 01:33:57 pm »
Hi DrMikeG2;

Welcome to the forum. Sorry to welcome you under such circumstances.

I won't be of much help. I have the first generation of P10's. They seem to have a different circuit board and firmware. My P10 if the bisquette burners do not work, my whole unit will shut down.

Send an email to Bradley customer support. It may be a failed burner plate, or burner sensor. If you get your problem resolved, it would be great if you post the solution. That will help others who have this problem. This has happened before to another member, but the person never posted if his problem was resolved, and/or how it was resolved.


     I
         don't
                   inhale.
  ::)