Puck advance problem

Started by David6340, October 21, 2004, 04:37:11 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I've noticed starting last Saturday, that the pucks do not advance all of the time. Most of the time, it seems to work but every now and then, I'll notice no smoke coming out of the BS. When I open the door, there is nothing on the plate. When I try to use the advance button, I'll hear the sound of a puck trying to advance but nothing happens even with a full tube of pucks. I'll press it another time and it starts to advance. I've had the BS since last July and have had no mechanical problems until now. I'm assuming that my best bet would be to call Bradley but any suggestions would be appreciated. Thanks.

<font color="blue">Dave</font id="blue"> [:)]

I Love The Smell Of BBQ In The Morning!


I had the same problem with mine. I did call Bradley and they sent me a new generator within 1 week.

Chez Bubba


If you've had it for over a year & never cleaned the generator, that's probably the problem. The bisquette "flake" will build up and combined with the smoke residue, will tend to bind up the moving parts.

There are 6 screws on the perimiter of the bottom of the generator. Unscrew these, disconnect 3 wires & you will have it mostly apart. You may want to also remove the 4 screws holding the feeder base to clean around the puck pusher. An old toothbrush works great.

I generally give mine a good cleaning once a year, but will alter that schedule based on the amount of activity it's had.


Ya think next time I check into a hotel & they ask "Smoking or Non?" they would mind?
Ya think if next time I check into a hotel & they ask "Smoking or Non", they would mind?


Mike & Kirk,
Bradley sent me a new generator. Arrived in one day. Kirk, they did say the same thing that you suggested about removing the screws, taking it apart and cleaning it periodically. They also suggested that I use a vacuum to remove particles on a regular basis. The only thing that scares me is that taking things apart and putting it back together is not one of my strong points.[:(] I guess I'll have to do it because they are not going to replace the generator a second time.

<font color="blue">Dave</font id="blue">

I Love The Smell Of BBQ In The Morning!


I am also experienceing the same problem.  I have only used it twice.  It seems the "pusher plate" is only coming back about half way and then moving forward.  It is a hit and miss, on occasion it will work fine but then it will not do the next cycle.  I have tried pushing the button and then same thing is happening.  I have tried blowing it out with compressed air to see if that would help and it did not.  Almost seems like it is binding on something.  


I had this problem and what I did was unplug the unit to reset it.
After that it is working fine, but I try to keep it as clean as possible.
Keep on smokin
Catch it,Kill it,Smoke it.