Help replacing heat element plug

Started by Victoriad, June 25, 2021, 11:35:32 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I bought a replacement fir heat element because I've been getting E1 error message. I cleaned it and tried all the online suggestions I could find before purchase.

When I plugged in new cord, I still get same error message, so I'm thinking it's the plug that needs fixing. I have a new plug, just not sure how to go about replacing it. Any help is most appreciated!


Here's a summary of the E1 error from the old Bradley FAQ section on a forum that's no longer online.

Q. Why does my Digital Bradley Smoker starts OK then beeps and displays an E1 error on the screen?

A. The E1 error is usually an issue with the TC wire (small wire between generator and tower). If you unplug and re-plug it a couple of times or even unplug and reverse it, it will usually help. I found that the problem only happened a couple of times. Once I had unplugged and re-plugged a couple of times it seemed to resolve it. It was almost like it had some rough cast plastic in the pin part of the connector or something.

Additional Information from the Bradley website:
An "E1" message is something to do with the sensor cable. The sensor cable is the short skinny cable that runs from the generator to the tower. Please make sure that it's connected, secondly unplug it and switch the ends around, so plug "A" side into "B" and the "B" side into "A" sometime that makes a better connection. Also make sure that there is nothing blocking that connection ie: loose chips, dust (using a piece of steel wool or super fine sandpaper to clean the ends of your sensor cable works well).

Also; while the generator is on and the "E1" error is displayed and beeping, check the connection by wiggling one side of the connection up and down and left to right, and then the other side. If the "E1" message temporally goes away while you were wiggling one side, you need a new sensor connector. 

If none of the above actions work, the E-1 error may be a bad connection to the temp sensor the connection is located in the back of the smoke tower remove the back of the smoker and check the connection.