advance button not working

Started by aeisler, February 09, 2009, 07:18:48 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I just got an OBS and the advance button doesn't seem to be working. I push the button and nothing happens, the lights are on and it gets hot. Am I doing something wrong or is it defective?

Bradley (Head Office)

Hi Aeisler

If your advance button is not advancing a bisquette when you depress it you will have to open the generator up and check the connection to the button
To open the generator up flip it upside down and remove the 8 screws that are around the outside edge (do not remove the screws in the middle)
when you have the screws out stand it up and pull the top of it off.
When you get it apart look for the 2 wires that come off the advance button follow them down to the connector and check that connection.
If the connection is ok then call the office 1-800-665-4188 in the morning and tell them you need a new advance button.

Hope this helps



Mine was not working, opened it and the switch was not connected.  Easy repair, even I could do.


Way to go, another quick fix  ;)


Wonder how this gentleman made out...was the problem solved.???
Digital Bradley Smoker with Dual probe PID
The Big Easy with Srg grill
MAK 2 Star General
Char Broil gas grill

Bradley (Head Office)

Quote from: ghost9mm on April 27, 2011, 11:53:44 AM
Wonder how this gentleman made out...was the problem solved.???

I sure hope it was solved that post was posted in Feb 2009 that would be some bad customer service on our part  :D :D :D


I just bought an Original Bradley Smoker two days ago and used it yesterday for the first time.  The advance button sticks every time, right out of the box.  I read some of the posts with similar problems.  I guess this is quite a common occurrence.  I called the office and they said they'd send me out a new one and gave me instructions (which I already read here on the forum) for a temporary fix.  Obviously I haven't received the new button yet, but I'm optimistic in the outcome based on the conversation that I had with Jessica at Bradley.  I'll follow up when I get the new button and get it resolved. 

I was fortunate to figure out it was sticking since it was the first time I'd used it and didn't really know what correct operation was.  But I figured after it kept advancing and advancing that the button was probably stuck....and it was.  Fortunately I didn't lose any pucks to the water but I had to catch them until I could get the button unstuck....which took some effort.  After that, the smoker worked great.  Did some pork chops with apple pucks that turned out great.  Now, to get that button fixed and move on to more smoke!


Got my button in the mail like 3 days after I called.  Got it installed in like 10 minutes.  Putting it to the test tomorrow with a Boston Butt I've got in the fridge getting right.  Looks like the button works just fine now.